RSS-Probleme mit WordPress 2.0.6: Bug-Fix verfügbar

Ein aufmerksamer Leser des RSS-Feeds der Mexiko Travelnews war so freundlich, darauf hinzuweisen, dass besagtes Feed mit dem “My Yahoo! Reader” nicht mehr funktionieren wollte. Mein Dank dafür geht diesmal an Herrn B. in die Schweiz.

Während das Feed mit dem Internet Explorer problemlos lesbar war, konnte es mit Firefox nicht mehr geladen werden. Ob Firefox ein zuverlässiges Hilfsmittel ist, um festzustellen, ob man vom Update-Problem betroffen ist, vermag ich nicht zu sagen. Sicher ist jedoch, dass alle anderen bisher durchgeführten WordPress-(2.0.6)-Updates mit Firefox keinerlei Ladehemmungen zeig(t)en, während das Mexiko-Feed, wenn überhaupt, nach dem Update nur noch “zufällig” geladen und angezeigt werden konnte.

Scheinbar wurde das WordPress-Update vor der Veröffentlichung (nur) mit einer CGI-Konfiguration getestet. Denn, wie sich herausstellte, enthält das WordPress 2.0.6-Update einen kleinen Fehler, der nur unter bestimmten Server-Voraussetzungen auftreten soll. Demnach bekommt man RSS-Feed-Probleme nur auf solchen Servern, bei denen der Apache-Server nicht für CGI oder FastCGI, sondern für die Verwendung von mod_php konfiguriert ist. (Diese Variante gilt allgemein als etwas “schneller”, dafür aber auch als etwas “unsicherer” als CGI-Konfigurationen.)

Eine modifizierte Datei namens “functions.php” steht bereits bei Perun zum Download bereit. Sie kann gegen die alte Datei im Ordner /wp-includes/ ausgetauscht werden, um das RSS-Feed-Problem zu lösen. Gefunden habe ich des Rätsels Lösung über einen Hinweis im WordPress-Forum, der leider nicht mehr auffindbar ist. Dort ebenfalls entdeckten Spekulationen zu Folge wird es demnächst nun doch noch ein 2.0.7 – Update geben, bevor WordPress 2.1 das Licht der Welt erblickt.

RSS-Probleme mit WordPress 2.0.6: Bug-Fix verfügbar

Benutzerinformation und Links:

37 Kommentare zu “RSS-Probleme mit WordPress 2.0.6: Bug-Fix verfügbar”

  1. […] fob marketing (Home) » Marketing Blog » Internet, Blogs und Blogging, WordPress » Blog-Artikel: WordPress 2.0.6 Update – Suche, Tagging, Bug-Fixes « RSS-Probleme mit WordPress 2.0.6: Bug-Fix verfügbar […]

  2. FerienNews

    Wir haben das gleiche Problem mit RSS Popper gehabt, immer Fehlermeldungen. Nun klappts prima !

  3.   fob

    Fein. 😉

  4. Ace Dahlmann

    Ich habe sowohl das Update der functions.php getestet als auch ein Update auf 2.0.7-RC1 gewagt. Bei mir bringt beides leider keine Verbesserung bei dem Feed-Problem. 🙁

  5.   fob

    Wo liegt denn das Feed?

  6. Ace Dahlmann

    http://schmittis-welt.de/
    Ich hab jetzt schon einiges probiert. Inzwischen ist die 2.0.6 wieder drauf (die functions.php ist aber wieder durch den Patch ausgetauscht), und ich habe auch einige andere Leute testen lassen. Es geht nicht.

  7.   fob

    Wo gibt`s denn WordPress 2.0.7 RC-1? 😉

  8. Ace Dahlmann

    http://markjaquith.wordpress.com/2007/01/11/wordpress-207-rc1-on-wp-testers/

  9.   fob

    O.k… ich schau gerade mal. Schicke Seite. 😉

  10.   fob

    Schon mal mod_rewrite probiert?

  11.   fob

    Bei mir geht`s: Schmittis-Welt-Feed (Beitrag Nr. 2) / komplettes Feed (?)

    Ich würde aber trotzdem die Verwendung “sprechender URLs” empfehlen.

  12. Ace Dahlmann

    Sicher? Auch wenn Du ihn nochmal löschst und wieder bestellst oder so? Bei meinen Testern geht es nicht.
    @mod_rewrite: Nee, ich glaube nicht (solange das nicht Standard ist). Eine .htaccess hab ich allerdings nicht.

  13.   fob

    Kleine Späßchen von Spam Karma 2. Sorry. Ja, sicher. Funktioniert. Ich würde wohl meinen, mod_rewrite ist schon lange “Standard”. Kannst Du unter “Verwaltung” einfach einstellen, die sprechenden URLs… Den Rest macht dann WordPress für Dich. Auch für die Feeds. 😉 ( Admin -> Optionen -> Permalinks … und dann z.B. “basierend auf Datum und Name” )

  14. Ace Dahlmann

    Ja, das muss und wollte ich auch noch einrichten.
    Übrigens: Nicht vergessen, dass der Fehler nur im FF auftaucht. Hab es auch gerade nochmal getestet und von wem anders testen lassen. Im FF funzt es immer noch nicht. :-\

    Ich geb für heute erstmal auf. Auch wenn es sehr schade ist, da wir die Seite gerade erst gestern online gestellt und eine Rundmail verschickt haben, und nun bockt der RSS-Feed rum. 🙁

  15. Ace Dahlmann

    Ja, dass man die Permlinks einfach einstellen kann, weiß ich. Nur braucht man für mod_rewrite doch noch Zusatz-Optionen in der .htacess, oder? Nun, und dass der Feed immer noch nicht geht, hat ja nix mit den Permlinks zu tun, oder?
    Was mich allerdings sehr wundert und ärgert. Die Leute, die in den Berichten wegen des RSS-Problems in 2.0.6 die neue functions.php genommen haben, haben das Problem so lösen können. Nur bei mir klappt es weiterhin nicht. :\

  16.   fob

    Ich habe das Feed mit Internet Explorer 7, Firefox 1.0.7 und Firefox 2.0.0.1 getestet. Soweit ist alles o.k.. Wie ist denn der Server konfiguriert, läuft PHP über CGI oder als Apache-Modul? Sieht für mich so aus, als würde das Feed prima funktionieren.

  17. Ace Dahlmann

    Versteh ich nicht. Bei mir (Firefox 2.0) und bei nem Kumpel (FF 1.5) klappt es nicht. Auch bei einem, den ich eben am Telefon hatte (ich glaube FF 1.0.7) ging es nicht (alles Linux-FF übrigens).
    Ich habe hier auch schonmal die ganzen Browsereinstellungen gelöscht, obwohl ich der Meinung bin, dass es daran nicht liegen kann

    Ich weiß nicht, ich glaube ohne.

  18.   fob

    Sorry, chatten im Blog klappt nicht so doll. Der Spam-Schutz macht mich ganz irre. 😉
    Yahoo-Test negativ. Neue functions.php online? Permalinks schon mal resettet?

  19. Ace Dahlmann

    Ja, hab’s schon gemerkt. Aber ich muss für heute sowieso erstmal aufhören.
    Ja, die neue functions.php ist definitiv mit der alten überschrieben, das ist ja das Ärgerliche. :-[
    Die Permalinks habe ich soeben gerade erst eingerichtet. Ich musste erstmal suchen, was ich in die .htaccess schreiben muss. (Dort kann aber sonst nichts fehlen, oder? Ich habe vorher, bei der Ersteinrichtung (2.0.5) gar keine .htaccess gehabt (wie auch bis gerade eben), und der Feed hat mit der 2.0.5 noch einwandfrei funktioniert.

    Heiß negativ in dem Fall, dass es auch mit Yahoo funktioniert, wo der Fehler auftrat?
    Kann es möglicherweise daran liegen, dass der Patch die Linux-FF-Fehler noch nicht beseitigt, sondern nur die vom Windows-FF? Falls das sein könnte, kann jemand das entsprechend prüfen oder weiterleiten?

  20.   fob

    Die neue muss über die alte rüber… 😉

  21. Ace Dahlmann

    So war’s auch gemeint. 😛

  22.   fob

    Die Browser-Frage ist eine gute Frage für das WordPress-Forum (http://forum.wordpress-deutschland.org/). Allerdings geht es ja hier eigentlich um etwas ganz anderes, nämlich die Meldung an den Browser, dass das Feed in der erlaubten Zeit nicht ausgeliefert werden konnte, weshalb die Verbindung unterbrochen und das Feed nicht ausgeliefert wird (Error 305, glaube ich).

  23. Ace Dahlmann

    OK, ich hab’s mal dahin gepostet:
    http://forum.wordpress-deutschland.org/showthread.php?p=79913#post79913

    Nun, aber wie gesagt, ich muss für heute erstmal aufhören, danke erstmal und bis dann.

  24.   fob

    Das Problem scheint mir ein Validitätsproblem zu sein:

    1. Dem Feed werden keine vollständigen URLs übergeben: siehe Feed-Validator
    (Relative, statt statische Adresse in der header.php verwendet.)

    2. Das Template ist nicht valide: HTML-Probleme (Code säubern.)

    Beides korrigieren, dann wird`s laufen…

  25. Ace Dahlmann

    Ich habe es allerdings auch schon einmal mit dem Theme probiert, das ich zuvor installiert hatte. Das hatte auch nichts gebracht. Aber ich teste es gerne nochmal – und um ganz sicher zu gehen – mit geleertem Cache.

  26. Ace Dahlmann

    Hey! Ja, in der Tat, das war es! 🙂 Danke! 🙂
    Nur schade um das Theme, es war so schön. 🙁

  27.   fob

    Wieso schade um das Theme? Kann man doch verwenden? (Nur möglichst als CSS-Version ;-))

  28. Ace Dahlmann

    Wie meinste das?
    Nun, man kann es möglicherweise säubern und reparieren, aber ich bin kein php-Mann. Ich hab gerade mal geschaut: Die header.php ist ja nun wirklich nicht groß. Allerdings wüsste ich auch nicht, was ich da ändern müsste.

  29. Ace Dahlmann

    Hmm, im jetzigen Theme wird der Fehler mit den URLs im Feed aber immer noch angeprangert. Bei diesem funktioniert es jedoch. Dann ist es wohl der restliche Code der Seite, was? Das wäre ja noch mehr Arbeit. Ich schreib wohl mal lieber den Coder vom Theme an. 😉

  30. Ace Dahlmann

    OK, noch ein letztes Posting. 😉

    Es liegt an dem Theme, ABER: Nicht an der Validität. Ich habe hier auch nochmal was dazu geschrieben:
    http://forum.wordpress-deutschland.org/showthread.php?p=79925#post79925

  31.   fob

    Moin Ace,

    wer mit RSS-Feeds arbeiten möchte, sollte sicher stellen, dass der Code mit sauberem XHTML und CSS geschrieben ist, also “valide” im deklarierten Standard übergeben wird, weil die Verteilung der Feed-Inhalte sonst sehr fehleranfällig ist.

    Dein Theme ist zwar nicht unmittelbar für die Ausgabe der Feed-Inhalte verantwortlich (das Feed zieht sich nur den Inhalt der Seiten, um diesen im jeweiligen Feed-Standard wiederzugeben), wird jedoch zu fehlerhaften Darstellungen der Homepage in verschiedenen Browsern führen, wenn es nicht “sauber” codiert wurde. Browser versuchen zwar von alleine, solche HTML-Fehler (so gut sie können) auszugleichen, wenn sie aber “daneben tippen”, sieht`s schlecht aus…

    Mit der Doctype-Deklaration (header.php) wird einem Browser signalisiert, um welche Art Dokument es sich handelt. WordPress z.B. signalisiert dem Browser, dass die Seite mit einer Codierung nach dem XHTML 1.0 Transitional -Standard codiert wurde und Inhalte im Zeichensatz “UTF-8” verarbeitet. Wenn man vermeiden möchte, dass dem einen oder anderen das Design “um die Ohren fliegt”, sollte man sich bei der HTML-Programmierung an den XHTML-Standard und beim Speichern der Inhalte an den “UTF-8-Standard” halten (Datenbankeinstellung, um “komische Zeichen im Text” zu vermeiden).

    Standards sind dazu da, WebSites und Browser kompatibel zu machen, was für Feeds eine zwingende Voraussetzung ist, um Inhalte fehlerfrei mit anderen Seiten/Readern austauschen zu können.

    An die verschiedenen RSS-Standards (Feed-Weichen für veraltete Reader) habe ich gestern nicht mehr gedacht. Sorry. Standards, Browser und RSS-Standards entwickeln sich immer weiter. Für das Standard-WordPress-Feed wird die wp-rss2.php verwendet. Sie gibt den Code im Format RSS2.0 wieder, was jeder aktuelle Reader unterstützen sollte. Ältere Feed-Reader sollte man einfach einem Update unterziehen. 😉 Für ältere Browser kann man ein Feed-Design mit XSLT erzeugen, damit Feed-Leser nicht nur Code sehen, sondern Texte und Links, mit denen sie etwas anfangen können.

    Ich persönlich halte es zwar eigentlich für überflüssig, Feeds in veralteten Standards anzubieten (das gilt nicht für die XSLT-Browserweiche), für Online Services wie FeedBurner bietet es sich jedoch an, Atom-Feeds zu verwenden. Biste ja schon drauf gekommen. I.d.R. reicht es, den jeweiligen Feed-Readern einfach die passende URL anzubieten. So kann man dem Feed-Reader meist direkt mitteilen, ob er das Standard-Feed ( /feed/ ) , das Kommentar-Feed ( /comments/feed/ ), ein Seiten-, Artikel- oder eben ein ATOM-Feed ( /feed/atom/ ) verwenden soll.

    Wie man die Feed-Weiche für den Fall der Fälle in das Theme integriert, falls Feed Reader danach fragen, hast Du ja “gestern” noch herausgefunden. Dann ist ja jetzt wahrscheinlich alles klar…Viel Erfolg!

  32. Depol

    Hi, ich bin auch noch mit WP 206 zugange und habe das gleiche Problem. Ist das eigentlich mit der aktuellen WP-Version gelöst?

  33. Keven

    Das Problem mit invalidem Feed-Code wird ewig bestehen – weil mache Plugins Sachen in den Feed reinschreiben und sich nicht besonders genau um die Doctype-Declaration kümmern.

  34. Webtrends

    WordPress immer am aktuellen Versionsstand zu halten ist auf jeden Fall eine gute Idee.

  35. Torsten

    Ich hab bisher keinen RSS-Reader erlebt, der nicht mit irgendeinem RSS-Feed Probleme hatte. Das wird wohl auch in zehn Jahren noch so sein.

  36. seoblogger

    bei mir waren die leerzeilen am anfang und am ende einer jeden .php datei schuld…danach lief alles wieder einwandfrei!

  37. blubblub

    bei mir war das auch so


fob marketing Marketing Consulting Hamburg Marketing Werbung Internet PR Suchmaschinenoptimierung Kontakt Impressum Datenschutz